In Triofox, if you receive a 'lock lost' message, similar to the one shown below, indicating that a lock on a specific file has been broken, and whether you want to regain the lock. What does the message mean?
How the locking works in Triofox:
- When distributed locking is on (it is on by default), opening a file in the client will lock the file automatically. It will prevent other users from modifying the file. Once you close the file, it will be uploaded to the cloud, and the lock will be released.
- While you are working on the file, the Triofox client will keep the lock heartbeat with the Triofox server to maintain the lock. If the server doesn't hear from the client for 15 minutes, it will assume the client is gone and unlock the file to prevent the file from locking permanently.
- The error message means that while you still have the file open, you have lost the lock now. And it gives you the option to lock the file again.
Possible cause:
- An admin might have released the lock from the web portal directly.
- When you have a file opened and the machine goes into sleep mode, the Triofox Windows client cannot send heartbeat messages anymore.
- You have a network issue that prevents the Triofox Windows client from communicating with the server for the heartbeat message.
Solutions:
- If you are still working on the file, just click 'yes' to grab the lock again.
- If your machine does not go into sleep mode, please check your network connection.
As an admin, you can define how long the server will release the lock when it doesn't receive the heartbeat message. The setting is under System Info > Cluster Settings > Timeouts and Limits > Distributed Lock Idle Timeout.
Comments
0 comments
Please sign in to leave a comment.